Ticket #306 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Display of Default Site License and Licenses lists differs

Reported by: mura Owned by: brent
Priority: minor Milestone: 2.2.0
Component: ContentLicensing Version: Seattle 2.2.0-rc2
Keywords: Cc:

Description

With the out of the box licenses, Default Site License shows:

Creative Commons License : Attribution-Noncommercial-Share Alike 2.5

but, Licenses shows:

Creative Commons License

Change History

comment:1 Changed 8 years ago by dray

  • Status changed from new to closed
  • Resolution set to wontfix

This is by design.

The Default Site License gives the specific type of Creative Commons License that has been set for the Site Default.

The Supported Licenses gives the generic Creative Commons License, since the widget displayed is the CC License Picker, which happens to have the default value the same as the Site Default.

comment:2 Changed 8 years ago by mura

  • Status changed from closed to reopened
  • Resolution wontfix deleted

What happens if I have two default Creative Commons Licenses, I won't be able to tell the difference in the picker.

comment:3 Changed 8 years ago by mura

And if they are the same license, why can't I tell that from this screen?

comment:4 Changed 8 years ago by dray

  • Status changed from reopened to closed
  • Resolution set to fixed

The picker is not a license. If you had multiple Creative Commons Licenses as supported licenses, those would have to be manually entered into the system.

Presumably, you would name them differently, making the differentiation visually apparent. For example, Creative Commons Attribution 3.0 License and Creative Commons Attribution-NoDerivs? 3.0 License would be legitimate examples of end user created Supported Licenses. This would eliminate the need to use the picker, for licenses that are used 'often', but not enough to make them the default site license.

We have changed the language to read Creative Commons License Picker in the Supported Licenses, and amended the help text to define more succinctly what exactly the choice does for the site.

Note: See TracTickets for help on using tickets.